启封管理咨询

修身,齐家,治国,平天下
热 线 电 话 400-618-3060

X3 V7至V12安装及不同版本对软件环境的要求

Database

ComponentV7Update 8Update 9Version 11Version 12
Oracle 11gR2 SE, EE 11gR2 SE, EE (upgrade only); 12c SE, EE 11gR2 (upgrade and compatible only); 12c SE, EE 12c R1 SE2, EE 12c R1 and R2 SE2, EE
MS SQL Server 2012 SP2 SE, EE 2012 SP2 SE, EE (upgrade only); 2014 SE, EE, BI 2012 SP2 SE, EE (upgrade and compatible only); 2014 SE, EE, BI 2016, 2014 SE, EE, BI 2017, 2016, 2014 SE, EE, BI
MongoDB 2.4 2.6 3.0 to 3.4 3.2.6 to 3.4 3.4

Server OS

ComponentV7Update 8Update 9Version 11Version 12
Windows Server 2008R2, 2012 2008R2 (upgrade only), 2012 2012, (2008R2 upgrade and compatible only) 2016, 2012 2016, 2012
Red Hat Enterprise Linux 6.2+ 6.2+ 7 (6.2+: compatible only) 7+ 7+ (7.5 or later is recommended)
Oracle Enterprise Linux 6.2+ 6.2+ 7 (6.2+: compatible only) 7+ 7+ (7.5 or later is recommended)
AIX 7.1 7.1 To be deprecated. No new configuration should be allowed with AIX To be deprecated. No new configuration should be allowed with AIX Deprecated (except if used as database server configured manually)

Servers, Frameworks and Middleware

ComponentV7Update 8Update 9Version 11Version 12
node.js 0.10.46 0.10.46 0.12.15 to 8.11.3 4.6.0 to 8.11.3 8.11.3
elasticsearch 0.90.* 0.90.* 1.5.* 1.5.* 2.4.4, 6.4 since release 2019.R3
JVM 7+ 7+ 7+ 8 (7+) 8
Tomcat          
Apache 2.2 2.2.25 2.2.25 2.2 2.4
BO Business Object XI 4.1 SP3 patch 1 Business Object XI 4.1 SP3 patch 1 Business Object XI 4.1 SP3 patch 1 Business Object XI 4.1 SP3 patch 1 Not available
.Net framework 3.5 and 4 3.5 and 4 3.5 and 4 3.5 and 4 3.5 and 4

Browsers

ComponentV7Update 8Update 9Version 11 (or above)
Google Chrome v33+ v38+ v45+ v48+
Firefox v28+ v36+ v41+ v44+
Opera v20+ v28+ v31+ v35+
Safari (Mac OS only) v6+ v7+ v8+ v9+
IE, Edge IE10, IE11 IE10, IE11 IE11, Edge (IE10: only compatible) IE11, Edge (EdgeHTML 15)

Note: Desktop browsers are certified on Windows 7, Windows 8.1, Windows 10 (Edge only on Windows 10), and Mac OS X. Other linux-based systems are "compatible only".

Mobility

ComponentV7Update 8Update 9Version 11 (or above)
iOS 7+ 8+ 8+ 10 (may run on 9 but this is now an old iOS version)
Android 4.2+ 4.2+ 4.3+ 7 (Nougat)
Windows Phone n/a 7.1+ (IE11+) 7.1 (IE11) 8.1
Windows RT n/a 8.1+ (IE11+) 8.1+ (IE11+) 8.1
Windows n/a Windows 8.1+ (IE11+) Windows 8.1+ (IE11+) 8.1

Client Components

ComponentV7Update 8Update 9Version 11Version 12
MS/Office (32 and 64 bit editions). *Requires IE10+ 2010, 2013 2010, 2013 2010, 2013, 2016 2010, 2013, 2016 2010, 2013, 2016
MS/Office as part of Office 365 (32 and 64 bit editions) on-premise. No support for Office online. *Requires IE10+ - - 2013, 2016 2013, 2016 2013, 2016
MS/Outlook (32 and 64 bit editions). - 2010, 2013 2010, 2013, 2016 2010, 2013, 2016 2010, 2013, 2016
MS/Outlook as part of Office 365 (32 and 64 bit editions) on-premise. No support for Office online. - - 2013, 2016 2013, 2016 2013, 2016
Ilog Unsupported Win7, Win8.1 Win7, Win8.1, Win10    
Crystal Reports Designer CR2013 CR2013 - Required on all print servers with Oracle 12c CR2013 - Required on all print servers with Oracle 12c CR2013 - Required on all print servers with Oracle 12c CR2013 - Required on all print servers with Oracle 12c

Virtualization Systems

There are no issues running Sage X3 on a Virtualization System as long as it supports one of the Operating Systems supported by Sage X3, and as long as it is correctly administered (no "over provisionning").

本原创文章未经允许不得转载 | 当前页面:启封管理咨询 » X3 V7至V12安装及不同版本对软件环境的要求

评论