启封管理咨询

修身,齐家,治国,平天下
热 线 电 话 400-618-3060

X3 V12 安装要求

Java

Installers for Sage X3 components are based on IZpack open-source framework. They require Oracle Java Runtime Environment (JRE) 8 or higher to run.

Elasticsearch requires Oracle Java Development Kit (JDK) version 8 or higher to run.

After January 2019, Oracle’s policy regarding free availability of JRE/JDK version 8 will change. Due to this change, Sage X3 will support equivalent open source versions of JRE/JDK (OpenJDK builds).

.Net Framework

The following components require Microsoft .Net 3.5 and 4 Framework:

  • Sage X3 console
  • Sage X3 print server

OS/Database compatibility matrix for Sage X3 V12 server components

The table below describes the possible OS/database combinations for installing Sage X3 components.

Component nameRDBMS vendor/version/editionOperating systems on Intel x86_64 architectureComments
Microsoft Windows 2012R2 64-bitMicrosoft Windows 2016 64-bit

RedHat Enterprise

Linux 7.x (> 7.2) 64-bit

Oracle Enterprise

Linux 7.x (>7.2) 64-bit

Sage X3 database connector

Sage X3 runtime

Sage X3 application

SQL Server 2012

SE or EE

Compatible Compatible No

Mixing Windows and Linux platforms for these components in the application tier is not supported.

“Compatible” means that this combination is supported for upgrades from previous Sage X3 versions (formerly known as Sage ERP X3) but should not be used for new installations.

SQL Server 2014

SE or EE

Yes Yes No

SQL Server 2016

SE or EE

Yes Yes No

SQL Server 2017

SE or EE

No Yes No

Oracle 11Gr2 (11.2.0.4)

SE1, SE or EE

Compatible Compatible Compatible

Oracle 12cR1 (12.1.0.2)

SE2 or EE

Yes Reported to work but not formally validated by Oracle Yes

Oracle 12cR2 (12.2.0.1)

SE2 or EE

No Yes Yes
Apache HTTPD RDBMS-neutral Yes Yes Yes

Apache 2.2.x is deprecated, you should use Apache 2.4.

On Linux, you can use the HTTPD standard package based on Apache 2.4.

MongoDB RDBMS-neutral Yes Yes Yes

Installer on Sage X3 provides MongoDB 3.4.

Supported MongoDB versions: 3.0, 3.2 and 3.4.

Elasticsearch RDBMS-neutral Yes Yes Yes

Installer on Sage X3 provides Elasticsearch 2.4.4.

Supported versions: 1.5.x and 2.4.x.

Sage X3 console For all application tier supporting OS/database combinations Yes Yes No Can also be installed on users’ workstations running Windows 7, 8, 8.1 and 10.
Sage X3 print server For all application tier supported OS/database combinations Yes Yes No

Can also be installed on users’ workstations running Windows 7, 8, 8.1 and 10.

For test and development environments, not production.

Sage X3 ADC server RDBMS-neutral Yes Yes Yes -
Sage X3 JavaBridge RDBMS-neutral Yes Yes Yes To be deprecated in a future Sage X3 version.
本原创文章未经允许不得转载 | 当前页面:启封管理咨询 » X3 V12 安装要求

评论